import Foundation
let pattern = #"(?:\\begin\{equation\}|\G(?!^))(?:(?!\\a{}|\\(?:begin|end){equation}).)*\K\\a{}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
abc xyz \a{} mno
\begin{equation}
\a{}=a+c
\a{}=c+b
\end{equation}
klm mno
\begin{equation}
x=\a{}\times\b{}
\end{equation}
xyz mno \a{} abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"xyz"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)