$re = '/(?:\\\\begin\{equation\}|\G(?!^))(?:(?!\\\\a{}|\\\\(?:begin|end){equation}).)*\K\\\\a{}/ms';
$str = 'abc xyz \\a{} mno
\\begin{equation}
\\a{}=a+c
\\a{}=c+b
\\end{equation}
klm mno
\\begin{equation}
x=\\a{}\\times\\b{}
\\end{equation}
xyz mno \\a{} abc';
$subst = "xyz";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;