re = /(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>["'`])(?<string>[^"$'`{}]*)(?<quote2>["'`])(}))/m
str = '<ReactComponent
property={true}
target={\'string\'}
/>
export const ReactComponent = () => <div property target={"string"} />
<ReactComponent
property={true}
target={`string`}
/>'
subst = '$2$4$5$6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result