#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?m)(^\[assembly: System\.Reflection\.AssemblyVersion\(")[\d.]+"
Local $sString = "//------------------------------------------------------------------------------" & @CRLF & _
"// <auto-generated>" & @CRLF & _
"// This code was generated by a tool." & @CRLF & _
"// Runtime Version:4.0.30319.42000" & @CRLF & _
"//" & @CRLF & _
"// Changes to this file may cause incorrect behavior and will be lost if" & @CRLF & _
"// the code is regenerated." & @CRLF & _
"// </auto-generated>" & @CRLF & _
"//------------------------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"using System.Runtime.InteropServices;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[assembly: System.Reflection.AssemblyVersion("1.1.31.0")]" & @CRLF & _
"[assembly: System.Reflection.AssemblyCompany("Name")]" & @CRLF & _
"[assembly: System.Reflection.AssemblyProduct("Name")]" & @CRLF & _
"[assembly: System.Reflection.AssemblyCopyright("Name")]" & @CRLF & _
"" & @CRLF & _
"// Setting ComVisible to false makes the types in this assembly not visible" & @CRLF & _
"// to COM components. If you need to access a type in this assembly from" & @CRLF & _
"// COM, set the ComVisible attribute to true on that type." & @CRLF & _
"[assembly: ComVisible(false)]"
Local $sSubst = "${1}2.0.0.0_delta"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)