// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?m)(^\[assembly: System\.Reflection\.AssemblyVersion\(")[\d.]+"#).unwrap();
let string = "//------------------------------------------------------------------------------
// <auto-generated>
// This code was generated by a tool.
// Runtime Version:4.0.30319.42000
//
// Changes to this file may cause incorrect behavior and will be lost if
// the code is regenerated.
// </auto-generated>
//------------------------------------------------------------------------------
using System.Runtime.InteropServices;
[assembly: System.Reflection.AssemblyVersion(\"1.1.31.0\")]
[assembly: System.Reflection.AssemblyCompany(\"Name\")]
[assembly: System.Reflection.AssemblyProduct(\"Name\")]
[assembly: System.Reflection.AssemblyCopyright(\"Name\")]
// Setting ComVisible to false makes the types in this assembly not visible
// to COM components. If you need to access a type in this assembly from
// COM, set the ComVisible attribute to true on that type.
[assembly: ComVisible(false)]";
let substitution = "${1}2.0.0.0_delta";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}