import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(^\\[assembly: System\\.Reflection\\.AssemblyVersion\\(\")[\\d.]+";
final String string = "//------------------------------------------------------------------------------\n"
+ "// <auto-generated>\n"
+ "// This code was generated by a tool.\n"
+ "// Runtime Version:4.0.30319.42000\n"
+ "//\n"
+ "// Changes to this file may cause incorrect behavior and will be lost if\n"
+ "// the code is regenerated.\n"
+ "// </auto-generated>\n"
+ "//------------------------------------------------------------------------------\n\n"
+ "using System.Runtime.InteropServices;\n\n\n"
+ "[assembly: System.Reflection.AssemblyVersion(\"1.1.31.0\")]\n"
+ "[assembly: System.Reflection.AssemblyCompany(\"Name\")]\n"
+ "[assembly: System.Reflection.AssemblyProduct(\"Name\")]\n"
+ "[assembly: System.Reflection.AssemblyCopyright(\"Name\")]\n\n"
+ "// Setting ComVisible to false makes the types in this assembly not visible\n"
+ "// to COM components. If you need to access a type in this assembly from\n"
+ "// COM, set the ComVisible attribute to true on that type.\n"
+ "[assembly: ComVisible(false)]";
final String subst = "${1}2.0.0.0_delta";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}