package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/)?(?:www\.)?(?:youtube\.com\/watch\?v=([a-zA-Z0-9_]+)|youtu\.be\/([a-zA-Z\d_]+))(?:&.*)?$`)
var str = `http://www.youtube.com/watch?v=p72I7gRXpg
http://youtube.com/watch?v=bQVoAWSP7k4
http://www.youtube.com/watch?v=bQVoAWSP7k4
https://youtu.be/6WZoMAVCggM
http://www.youtube.com/watch?v=6WZoMAVCggM&
http://www.youtube.com/watch?v=bQVoAWSP7k4&feature=popular
http://www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah
www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah
youtu.be/6WZoMAVCggM
youtube.com/watch?v=bQVoAWSP7k4
http://youtube.com/watch?v=bQVoAWSP7k4
http://youtu.be/6WZoMAVCg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}