import re
regex = re.compile(r"^(?:https?:\/\/)?(?:www\.)?(?:youtube\.com\/watch\?v=([a-zA-Z0-9_]+)|youtu\.be\/([a-zA-Z\d_]+))(?:&.*)?$", flags=re.MULTILINE)
test_str = ("http://www.youtube.com/watch?v=p72I7gRXpg\n"
"http://youtube.com/watch?v=bQVoAWSP7k4\n"
"http://www.youtube.com/watch?v=bQVoAWSP7k4\n"
"https://youtu.be/6WZoMAVCggM\n"
"http://www.youtube.com/watch?v=6WZoMAVCggM&\n"
"http://www.youtube.com/watch?v=bQVoAWSP7k4&feature=popular\n"
"http://www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah\n"
"www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah\n"
"youtu.be/6WZoMAVCggM\n"
"youtube.com/watch?v=bQVoAWSP7k4\n"
"http://youtube.com/watch?v=bQVoAWSP7k4\n"
"http://youtu.be/6WZoMAVCg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")