using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:,|\n|^)(""(?:(?:"")*[^""]*)*""|[^"",\n]*|(?:\n|$))";
string input = @"""a"",""b"",c,""d"",e,f,,""g""
""""test"" one"",test' two,""""test"" 'three'"",""""test 'four'""""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}