package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))`)
var str = `"a","b",c,"d",e,f,,"g"
"""test"" one",test' two,"""test"" 'three'","""test 'four'"""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}