$re = '/(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))/';
$str = '"a","b",c,"d",e,f,,"g"
"""test"" one",test\' two,"""test"" \'three\'","""test \'four\'"""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);