#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(?<FirstPart>(?:<div>.*?){4}+).*?(<div>(?:(?!<\/?div>).)*(?:(?-1)*+|(?:(?!<\/?div>).))+<\/div>).*?(?<SecondPart>(?:<\/div>.*?){4}+)"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
"" & @CRLF & _
" <head>" & @CRLF & _
"" & @CRLF & _
" </head>" & @CRLF & _
"" & @CRLF & _
" <body>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" </body>" & @CRLF & _
"" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")