const regex = /(?<FirstPart>(?:<div>.*?){4}+).*?(<div>(?:(?!<\/?div>).)*(?:(?-1)*+|(?:(?!<\/?div>).))+<\/div>).*?(?<SecondPart>(?:<\/div>.*?){4}+)/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<FirstPart>(?:<div>.*?){4}+).*?(<div>(?:(?!<\\\/?div>).)*(?:(?-1)*+|(?:(?!<\\\/?div>).))+<\\\/div>).*?(?<SecondPart>(?:<\\\/div>.*?){4}+)', 'gis')
const str = `<!DOCTYPE html>
<html>
<head>
</head>
<body>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}