$re = '/(?<FirstPart>(?:<div>.*?){4}+).*?(<div>(?:(?!<\/?div>).)*(?:(?-1)*+|(?:(?!<\/?div>).))+<\/div>).*?(?<SecondPart>(?:<\/div>.*?){4}+)/is';
$str = '<!DOCTYPE html>
<html>
<head>
</head>
<body>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);