package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([A-Z]{1,3})\h+([A-Z]{1,3})[-*]`)
var str = `D HG-ABCDE : Country should be D, District should be HG
A S-FGHIJ : Country should be A, District should be S
D AC-KLMNO : Country should be D, District should be AC
A BR-PQRST : Country should be A, District should be BR
A RO*UVWXY : Country should be A, District should be RO
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}