import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([A-Z]{1,3})\\h+([A-Z]{1,3})[-*]";
final String string = "D HG-ABCDE : Country should be D, District should be HG\n"
+ "A S-FGHIJ : Country should be A, District should be S \n"
+ "D AC-KLMNO : Country should be D, District should be AC\n"
+ "A BR-PQRST : Country should be A, District should be BR\n"
+ "A RO*UVWXY : Country should be A, District should be RO\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}