# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b([A-Z]{1,3})\h+([A-Z]{1,3})[-*]"
test_str = ("D HG-ABCDE : Country should be D, District should be HG\n"
"A S-FGHIJ : Country should be A, District should be S \n"
"D AC-KLMNO : Country should be D, District should be AC\n"
"A BR-PQRST : Country should be A, District should be BR\n"
"A RO*UVWXY : Country should be A, District should be RO\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.