#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\d+\K[^a-z]*"
Local $sString = "12jan" & @CRLF & _
"12 jan" & @CRLF & _
"12 jan" & @CRLF & _
"12/jan" & @CRLF & _
"12//jan" & @CRLF & _
"12/jan" & @CRLF & _
"12*/jan" & @CRLF & _
"12*//jan"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")