$re = '~\d+\K[^a-z]*~i';
$str = '12jan
12 jan
12 jan
12/jan
12//jan
12/jan
12*/jan
12*//jan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);