re = /\d+\K[^a-z]*/i
str = '12jan
12 jan
12 jan
12/jan
12//jan
12/jan
12*/jan
12*//jan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end