#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "rustc (?<version>1.\d+.\d+)(?:(?:-(?:(?<nightly>nightly)|(?<beta>beta.*?))|(?:[^\s]+))? \((?:[^\\s]+) (?<date>\d{4}-\d{2}-\d{2})\))?"
Local $sString = "rustc 1.13.0 (2c6933acc 2016-11-07)" & @CRLF & _
"rustc 1.13.0-beta.3 (106d18793 2016-11-04)" & @CRLF & _
"rustc 1.14.0-nightly (cae6ab1c4 2016-11-05)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")