$re = '~rustc (?<version>1.\d+.\d+)(?:(?:-(?:(?<nightly>nightly)|(?<beta>beta.*?))|(?:[^\s]+))? \((?:[^\\\\s]+) (?<date>\d{4}-\d{2}-\d{2})\))?~';
$str = 'rustc 1.13.0 (2c6933acc 2016-11-07)
rustc 1.13.0-beta.3 (106d18793 2016-11-04)
rustc 1.14.0-nightly (cae6ab1c4 2016-11-05)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);