// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"rustc (?<version>1.\d+.\d+)(?:(?:-(?:(?<nightly>nightly)|(?<beta>beta.*?))|(?:[^\s]+))? \((?:[^\\s]+) (?<date>\d{4}-\d{2}-\d{2})\))?").unwrap();
let string = "rustc 1.13.0 (2c6933acc 2016-11-07)
rustc 1.13.0-beta.3 (106d18793 2016-11-04)
rustc 1.14.0-nightly (cae6ab1c4 2016-11-05)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}