#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)(<a href=")([A-z0-9-\/]+)(".*)"
Local $sString = "<a href="/" data-link-title="Start" class="cc-nav-current j-nav-current jmd-nav__link--current">Start</a></li><li id="cc-nav-view-2315645625" class="jmd-nav__list-item-0"><a href="/öffnungszeiten-schließzeiten/" data-link-title="Öffnungszeiten & Schließzeiten">Öffnungszeiten & Schließzeiten</a></li><li id="cc-nav-view-2316315025" class="jmd-nav__list-item-0"><a href="/flyer/" data-link-title="Flyer">Flyer</a></li><li id="cc-nav-view-2315732425" class="jmd-nav__list-item-0"><a href="/anfahrt/" data-link-title="Anfahrt">Anfahrt</a></li><li id="cc-nav-view-2315645825" class="jmd-nav__list-item-0"><a href="/kontakt-termin-verbeinaren/" data-link-title="Kontakt / Termin verbeinaren">Kontakt / Termin verbeinaren</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")