$re = '`(.*)(<a href=")([A-z0-9-\/]+)(".*)`m';
$str = '<a href="/" data-link-title="Start" class="cc-nav-current j-nav-current jmd-nav__link--current">Start</a></li><li id="cc-nav-view-2315645625" class="jmd-nav__list-item-0"><a href="/öffnungszeiten-schließzeiten/" data-link-title="Öffnungszeiten & Schließzeiten">Öffnungszeiten & Schließzeiten</a></li><li id="cc-nav-view-2316315025" class="jmd-nav__list-item-0"><a href="/flyer/" data-link-title="Flyer">Flyer</a></li><li id="cc-nav-view-2315732425" class="jmd-nav__list-item-0"><a href="/anfahrt/" data-link-title="Anfahrt">Anfahrt</a></li><li id="cc-nav-view-2315645825" class="jmd-nav__list-item-0"><a href="/kontakt-termin-verbeinaren/" data-link-title="Kontakt / Termin verbeinaren">Kontakt / Termin verbeinaren</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);