import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(<a href=\")([A-z0-9-\\/]+)(\".*)";
final String string = "<a href=\"/\" data-link-title=\"Start\" class=\"cc-nav-current j-nav-current jmd-nav__link--current\">Start</a></li><li id=\"cc-nav-view-2315645625\" class=\"jmd-nav__list-item-0\"><a href=\"/öffnungszeiten-schließzeiten/\" data-link-title=\"Öffnungszeiten & Schließzeiten\">Öffnungszeiten & Schließzeiten</a></li><li id=\"cc-nav-view-2316315025\" class=\"jmd-nav__list-item-0\"><a href=\"/flyer/\" data-link-title=\"Flyer\">Flyer</a></li><li id=\"cc-nav-view-2315732425\" class=\"jmd-nav__list-item-0\"><a href=\"/anfahrt/\" data-link-title=\"Anfahrt\">Anfahrt</a></li><li id=\"cc-nav-view-2315645825\" class=\"jmd-nav__list-item-0\"><a href=\"/kontakt-termin-verbeinaren/\" data-link-title=\"Kontakt / Termin verbeinaren\">Kontakt / Termin verbeinaren</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}