re = /<input type="hidden" name="csrftoken" value="(?P<token>.+?)"/m
str = '<input type="hidden" name="csrftoken" value="somerandomtokenvalue">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end