package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,3}(?:\.\d{1,2})?$`)
var str = `1
12
123
1.2
12.3
123.4
1.23
12.34
123.45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}