#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'CY)(?'tenoroffset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period')(?'year'\d{4})\b$"
Local $sString = "02_AUT_CY_PHY 2017" & @CRLF & _
"02_GASPOOL_H_CY_PHY 2017" & @CRLF & _
"02_GASPOOL_L_CY_PHY 2017" & @CRLF & _
"02_NBP_CY_PHY 2017" & @CRLF & _
"02_MGP_CY_PHY 2017" & @CRLF & _
"02_NCG_H_CY_PHY 2017" & @CRLF & _
"02_NCG_L_CY_PHY 2017" & @CRLF & _
"02_OTE_CY1_PHY 2017" & @CRLF & _
"02_POLVP_CY1_PHY 2017" & @CRLF & _
"02_PEGN_CY1_PHY 2017" & @CRLF & _
"02_SVKVP_CY1_PHY 2017" & @CRLF & _
"02_TTF_H_CY1_PHY 2017" & @CRLF & _
"02_ZEEBRUGGE_H_CY1_PHY 2017" & @CRLF & _
"02_ZTP_H_CY10_PHY 2015" & @CRLF & _
"02_ZTP_L_CY99_PHY 2015"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")