import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'commodity'02)_(?'market'\\w{3,})_(?'tenortype'CY)(?'tenoroffset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period')(?'year'\\d{4})\\b$";
final String string = "02_AUT_CY_PHY 2017\n"
+ "02_GASPOOL_H_CY_PHY 2017\n"
+ "02_GASPOOL_L_CY_PHY 2017\n"
+ "02_NBP_CY_PHY 2017\n"
+ "02_MGP_CY_PHY 2017\n"
+ "02_NCG_H_CY_PHY 2017\n"
+ "02_NCG_L_CY_PHY 2017\n"
+ "02_OTE_CY1_PHY 2017\n"
+ "02_POLVP_CY1_PHY 2017\n"
+ "02_PEGN_CY1_PHY 2017\n"
+ "02_SVKVP_CY1_PHY 2017\n"
+ "02_TTF_H_CY1_PHY 2017\n"
+ "02_ZEEBRUGGE_H_CY1_PHY 2017\n"
+ "02_ZTP_H_CY10_PHY 2015\n"
+ "02_ZTP_L_CY99_PHY 2015";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}