$re = '/^(?\'commodity\'02)_(?\'market\'\w{3,})_(?\'tenortype\'CY)(?\'tenoroffset\'[1-9][0-9]?)?_(?\'derivative\'PHY|FUT) (?\'period\')(?\'year\'\d{4})\b$/m';
$str = '02_AUT_CY_PHY 2017
02_GASPOOL_H_CY_PHY 2017
02_GASPOOL_L_CY_PHY 2017
02_NBP_CY_PHY 2017
02_MGP_CY_PHY 2017
02_NCG_H_CY_PHY 2017
02_NCG_L_CY_PHY 2017
02_OTE_CY1_PHY 2017
02_POLVP_CY1_PHY 2017
02_PEGN_CY1_PHY 2017
02_SVKVP_CY1_PHY 2017
02_TTF_H_CY1_PHY 2017
02_ZEEBRUGGE_H_CY1_PHY 2017
02_ZTP_H_CY10_PHY 2015
02_ZTP_L_CY99_PHY 2015';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);