$re = '/^\\\\tTitle = \{(.*)\},\\\\n$/m';
$str = '\\tTitle = {Regime legacies and levels of democracy: evidence from Latin America},\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);