re = /^\\tTitle = \{(.*)\},\\n$/m
str = '\\tTitle = {Regime legacies and levels of democracy: evidence from Latin America},\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end