#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).(.*)(]\s)(.[a-zA-Z]*)(..)(.*)"
Local $sString = "[1518-08-11 00:47] falls asleep" & @CRLF & _
"[1518-03-09 00:07] falls asleep" & @CRLF & _
"[1518-06-29 00:41] wakes up" & @CRLF & _
"[1518-05-27 23:58] Guard #743 begins shift" & @CRLF & _
"[1518-05-19 00:43] falls asleep" & @CRLF & _
"[1518-03-17 00:33] falls asleep" & @CRLF & _
"[1518-07-12 00:49] falls asleep" & @CRLF & _
"[1518-11-03 00:15] wakes up" & @CRLF & _
"[1518-06-05 00:57] wakes up" & @CRLF & _
"[1518-11-07 00:24] falls asleep" & @CRLF & _
"[1518-07-06 00:12] falls asleep" & @CRLF & _
"[1518-05-26 23:59] Guard #907 begins shift" & @CRLF & _
"[1518-06-01 00:28] wakes up" & @CRLF & _
"[1518-11-09 00:04] falls asleep" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")