# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".(.*)(]\s)(.[a-zA-Z]*)(..)(.*)"
test_str = ("[1518-08-11 00:47] falls asleep\n"
"[1518-03-09 00:07] falls asleep\n"
"[1518-06-29 00:41] wakes up\n"
"[1518-05-27 23:58] Guard #743 begins shift\n"
"[1518-05-19 00:43] falls asleep\n"
"[1518-03-17 00:33] falls asleep\n"
"[1518-07-12 00:49] falls asleep\n"
"[1518-11-03 00:15] wakes up\n"
"[1518-06-05 00:57] wakes up\n"
"[1518-11-07 00:24] falls asleep\n"
"[1518-07-06 00:12] falls asleep\n"
"[1518-05-26 23:59] Guard #907 begins shift\n"
"[1518-06-01 00:28] wakes up\n"
"[1518-11-09 00:04] falls asleep\n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.