package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).(.*)(]\s)(.[a-zA-Z]*)(..)(.*)`)
var str = `[1518-08-11 00:47] falls asleep
[1518-03-09 00:07] falls asleep
[1518-06-29 00:41] wakes up
[1518-05-27 23:58] Guard #743 begins shift
[1518-05-19 00:43] falls asleep
[1518-03-17 00:33] falls asleep
[1518-07-12 00:49] falls asleep
[1518-11-03 00:15] wakes up
[1518-06-05 00:57] wakes up
[1518-11-07 00:24] falls asleep
[1518-07-06 00:12] falls asleep
[1518-05-26 23:59] Guard #907 begins shift
[1518-06-01 00:28] wakes up
[1518-11-09 00:04] falls asleep
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}