using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<(?:\/)?)h4(?:.*?)(?<!>)";
string input = @"<a href=""#""><h4 class=""title"" id=""hello"">Hello!</h4></a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}