$re = '/(?<=<(?:\/)?)h4(?:.*?)(?<!>)/';
$str = '<a href="#"><h4 class="title" id="hello">Hello!</h4></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);