re = /(?<=<(?:\/)?)h4(?:.*?)(?<!>)/
str = '<a href="#"><h4 class="title" id="hello">Hello!</h4></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end