use strict;
my $str = '
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]
[[Nem tudom maygorul]] hungarian is difficult :)
[[Nem tudom maygorul]]';
my $regex = qr/(?s)\R\K\[\[((?:(?!\[\[|]]).)*)\R*]](?=\R)/mp;
my $subst = '## $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";