$re = '/(?s)\R\K\[\[((?:(?!\[\[|]]).)*)\R*]](?=\R)/m';
$str = '
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]
[[Nem tudom maygorul]] hungarian is difficult :)
[[Nem tudom maygorul]]';
$subst = "## $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;