import Foundation
let pattern = #"(?s)\R\K\[\[((?:(?!\[\[|]]).)*)\R*]](?=\R)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]
[[Nem tudom maygorul]] hungarian is difficult :)
[[Nem tudom maygorul]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ###"## $1"###
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)