re = /^[\w '-\/]+$/m
str = 'Jl. Merpati No. 3 RT/RW 001/012 (Bekas Jalan Manyar)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end