#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)<!-- @\[(\w+)\((\w+)\)\] -->\s+# ([\w ]+?)\s+<!-- @\[(\w+)\] -->\s+## ([\w ]+?)\s+```(\w+)\s+(.*?)```\s+<!-- @\[\/(\w+)\] -->"
Local $sString = "<!-- @[Hero(super)] -->" & @CRLF & _
"" & @CRLF & _
"# Creating new contexts" & @CRLF & _
"" & @CRLF & _
"<!-- @[UsageExample] -->" & @CRLF & _
"" & @CRLF & _
"## Usage example" & @CRLF & _
"" & @CRLF & _
"```javascript" & @CRLF & _
" Import { ICON_NAME } from 'Icons'" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"<!-- @[/Hero] -->" & @CRLF & _
"" & @CRLF & _
"<!-- @[ArticleSection] -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")