import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<!-- @\\[(\\w+)\\((\\w+)\\)\\] -->\\s+# ([\\w ]+?)\\s+<!-- @\\[(\\w+)\\] -->\\s+## ([\\w ]+?)\\s+```(\\w+)\\s+(.*?)```\\s+<!-- @\\[\\/(\\w+)\\] -->";
final String string = "<!-- @[Hero(super)] -->\n\n"
+ "# Creating new contexts\n\n"
+ "<!-- @[UsageExample] -->\n\n"
+ "## Usage example\n\n"
+ "```javascript\n"
+ " Import { ICON_NAME } from 'Icons'\n"
+ "```\n\n"
+ "<!-- @[/Hero] -->\n\n"
+ "<!-- @[ArticleSection] -->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}