const regex = /(?s)<!-- @\[(\w+)\((\w+)\)\] -->\s+# ([\w ]+?)\s+<!-- @\[(\w+)\] -->\s+## ([\w ]+?)\s+```(\w+)\s+(.*?)```\s+<!-- @\[\/(\w+)\] -->/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<!-- @\\[(\\w+)\\((\\w+)\\)\\] -->\\s+# ([\\w ]+?)\\s+<!-- @\\[(\\w+)\\] -->\\s+## ([\\w ]+?)\\s+```(\\w+)\\s+(.*?)```\\s+<!-- @\\[\\\/(\\w+)\\] -->', 'gm')
const str = `<!-- @[Hero(super)] -->
# Creating new contexts
<!-- @[UsageExample] -->
## Usage example
\`\`\`javascript
Import { ICON_NAME } from 'Icons'
\`\`\`
<!-- @[/Hero] -->
<!-- @[ArticleSection] -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}