$re = '/(?<=jw\.load\(\[\{ file: \')http[:\/a-zA-Z0-9_\.]+(?=\',)/';
$str = '<html>
<script>
jw.load([{ file: \'http://vrbx105.xxx.xx/U7yvQnLiA_m5mhE9MUHf3w/1477628604/vl107aeb2d7db53f91fc6ad2e76fe11e49.mp4\', provider: \'http\' }]);
</script>
</html>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);