import re
regex = re.compile(r"(?<=jw\.load\(\[\{ file: ')http[:\/a-zA-Z0-9_\.]+(?=',)")
test_str = ("<html>\n"
"<script>\n"
"jw.load([{ file: 'http://vrbx105.xxx.xx/U7yvQnLiA_m5mhE9MUHf3w/1477628604/vl107aeb2d7db53f91fc6ad2e76fe11e49.mp4', provider: 'http' }]);\n"
"</script>\n"
"</html>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")