import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=urce>)[\\s\\S]*?(?<=<\\/datas)";
final String string = "<id>SomeID</id>\n"
+ "<datasource>C:/projects/my_project/my_file.jpg</datasource>\n"
+ "<title>My title can include / and other characters</title>\n"
+ "<abstract></abstract>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}