re = /(?=urce>)[\s\S]*?(?<=<\/datas)/
str = '<id>SomeID</id>
<datasource>C:/projects/my_project/my_file.jpg</datasource>
<title>My title can include / and other characters</title>
<abstract></abstract>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end